amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

Installing XP on my Li 3910(with pre-installed Vista)

All problems with windows and windows drivers.

Installing XP on my Li 3910(with pre-installed Vista)

Postby MoonMan » Mon Feb 09, 2009 11:47 am

Hi,

I tried to install XP on my Amilo Li 3910, but everytime the installation stops with an error.
Now it seems that my laptop does not have the XP drivers that I need.
For some reason the Li3910 only supports Vista.

I cannot find the Xp drivers on the FS support page.
Is there anyone who can provide me the right XP drivers?

I also had some help from the Fujitsu forum, but I would like to have some more explanation on this.

Last week I contacted FS support and they told me to change the IDE settings under the tab Advanced in my BIOS.
Well, there is no such thing possible. The Advanced tab is not so advanced..... :roll:
I did a flash update of my BIOS to 1.05.
That's about it.

Since I want to use the laptop for recording audio, and Vista is a PITA for digital recording, I'd like to have XP installed on my machine.
Heck, I don't know why it's so hard to downgrade to XP.

Hopefully someone can help me out here.

Thanks!
MoonMan
 
Posts: 4
Joined: Mon Feb 09, 2009 11:32 am

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby aspettl » Mon Feb 09, 2009 2:36 pm

Did you see this thread?
topic,26,-Installation-of-Windows-XP-Home-Pro-PE-FAQs.html
(You have to integrate the AHCI driver, then XP detects the harddisk.)

Then you try to get the other drivers from the manufacturer of each component (or XP driver lists of similar notebooks ;-)).

Regards
Aaron
User avatar
aspettl
Site Admin
 
Posts: 1347
Joined: Sat Mar 25, 2006 3:31 pm
Location: Germany
Notebook:
  • Samsung NC10
  • Lifebook E8020D

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby hikaru » Mon Feb 09, 2009 3:45 pm

There is a thread in the german forum where amalek linked a rar-archive with the drivers he found:
https://www.amilo-forum.de/topic,26397,-Li-3910-Windows-XP.html

They should work for you too but maybe you will have to mess around with some german labels.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby MoonMan » Mon Feb 09, 2009 4:08 pm

Hi Aaron,

Yep, that was the first thing I read.
But how can I integrate the AHCI driver?
The support from FS told me to turn off ACHI and turn on IDE in Advanced tab in my BIOS, but I cannot find it there.
Advanced gives me two options.
Boot Diagnostic Screen (Disabled)
Wake up on LAN (Disabled)

The .pdf file about integrating the ACHI driver is no longer available.

And I did get drivers for the Li 3710, which is practically the same as the Li 3910.
I integrated the drivers via nLite, but with no result other than the BSOD.

What am I doing wrong?

-peter
MoonMan
 
Posts: 4
Joined: Mon Feb 09, 2009 11:32 am
Notebook:

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby MoonMan » Mon Feb 09, 2009 4:11 pm

hikaru wrote:There is a thread in the german forum where amalek linked a rar-archive with the drivers he found:
https://www.amilo-forum.de/topic,26397,-Li-3910-Windows-XP.html

They should work for you too but maybe you will have to mess around with some german labels.


Hi hikaru,

I'll see to that.
Thanks.

-peter
MoonMan
 
Posts: 4
Joined: Mon Feb 09, 2009 11:32 am
Notebook:

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby MoonMan » Mon Feb 09, 2009 11:12 pm

Got it up and running guys!

Thank you :)
MoonMan
 
Posts: 4
Joined: Mon Feb 09, 2009 11:32 am
Notebook:

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby chrisfesta » Sun Jul 26, 2009 7:34 pm

Hi,
I have a Fujitsu Amilo Li3910 & the above helped greatly. Who wants vista anyway!! I been tearing my hair out over this but just slip streaming the driver made it work. Use nLite & drivers from folder called "SATA Treiber für XP Setup" and put them in. message me if the drivers go offline, as I have a copy stored.

Good luck!
chrisfesta
 
Posts: 1
Joined: Sun Jul 26, 2009 7:30 pm

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby Trojan-Computers » Mon Jul 27, 2009 3:23 pm

hi the above worked fine for me but i also have xp 64bit operating system that i need help for? the drivers for the 32bit sata do not work on the 64bit xp disc any ideas??? cheers
Trojan-Computers
 
Posts: 1
Joined: Mon Jul 27, 2009 9:29 am

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby titus_lite » Thu Jul 30, 2009 5:46 pm

Hi guys,

I did manage to download the sata drivers from the german forum but i dont seem to get around completing the integration onto the xp installation cd.

Just a fews questions: 1) Do i have to choose a specific AHCI driver from the list or do i just go ahead and select all? (First attempt to select all sata drivers led to an error "This disk cannot be read because it contains an unrecognized file system"....)
2) Do i just need to integrate these sata drivers alone or am i forgeting some driver not mentioned on this forum?

Thanks.
titus_lite
 
Posts: 1
Joined: Thu Jul 30, 2009 5:38 pm

Re: Installing XP on my Li 3910(with pre-installed Vista)

Postby zhnzhn » Fri Nov 26, 2010 8:27 pm

Hi all,

First, I want to thank everyone who contributed to this post and other posts, especially amalek from the german forum.

Now, for anyone who still need some help, here is how I did :

1 - put my cd of XP in the cd driver (it's an sp3 pro of win xp I have).

2 - copy the file on the cd in a folder on my desktop.

3 - Download THIS. This is a zip files with the required ICH9 drivers that are missing and that's why you get the BSOD ;) (note that I simply reuploaded amalek's zip file so there is more source for this file that made my day!!! it's the exact same file). One downloaded, extract to desktop.

4 - get nlite and run it, choose the folder where you previously copied the xp cd. Then hit the "next" button until you reach the Task selection screen and switch to green the "integrate drivers" button (sorry if not exact, i did this in french). So next you should be able to integrate a "single driver" and now go to the folder "SATA Treiber für XP Setup" and select this inf file iaAHCI and finally select ICH9M driver.

5 - Rest if optional so integrate as you wish different drivers. Finally end with creating the new ISO, burn, and enjoy.

Hope this helps, if not, feel free to email me at : z h n z h n 3 0 9 AT h o t m a i l . c o m
:mrgreen:
zhnzhn
 
Posts: 1
Joined: Fri Nov 26, 2010 7:58 pm


Return to Windows

Who is online

Users browsing this forum: No registered users and 0 guests

cron