amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

Upgrade M3438G Video Card 6800go to 7800go from eBay

Display problems, black screen, TV-Out,...

Upgrade M3438G Video Card 6800go to 7800go from eBay

Postby jackhk » Thu Jun 01, 2006 8:08 pm

Hi.

I've bought an NVIDIA 7800Go MxMIII PCiEx Video Card from eBay ( http://cgi.ebay.it/ws/eBayISAPI.dll?Vie ... %3AIT&rd=1 ) in order to upgrade my laptotp (Amilo M3438G)

But i've got some problems.

When the card is mounted my notebook doesn't boot up.

The system start very few seconds and shut down.

It's very strange. I don't know why.

This 7800Go is MxMIII compliant like my 6800Go.

Why won't work?

I have tried to upgrade BIOS with Uniwill P71En0 BIOS 1.11 (same notebook, different seller) without results.
Now i've tried AlienWare m5700 (Uniwill p71en0 reseller) BIOS 1.12. Same result. Won't work. Damn.

Is possible to upgrade Video Card of Amilo M3438G????


Is the BIOS capable to recognize this card or others MxMIII PciEx cards???

Or is the PCIEx slot that have an insufficent voltage?


Thanks in advantage if somebody want to help my.
Last edited by jackhk on Fri Jun 02, 2006 12:05 pm, edited 3 times in total.
jackhk
 
Posts: 21
Joined: Thu Jun 01, 2006 4:56 pm

Postby Ice-tEA » Thu Jun 01, 2006 8:47 pm

Are you the guest from laptopvideo2go?

Anyway, I had a costumer replace his dead uniwill 6800 with a Arima card and it works without problems.
Upgrade your MXM graphics card!
http://Www.mxm-upgrade.com
Image
User avatar
Ice-tEA
 
Posts: 47
Joined: Sat Mar 25, 2006 3:31 pm

Postby jackhk » Fri Jun 02, 2006 12:25 am

Nope.

Now i'm going to post to laptopvideo2go.

Have you any link about M3438G over there?
jackhk
 
Posts: 21
Joined: Thu Jun 01, 2006 4:56 pm

Postby Ice-tEA » Fri Jun 02, 2006 7:59 am

Same problem ->

http://www.laptopvideo2go.com/forum/ind ... c=9832&hl=

EDIT: Are you any good with a soldering iron?
Upgrade your MXM graphics card!
http://Www.mxm-upgrade.com
Image
User avatar
Ice-tEA
 
Posts: 47
Joined: Sat Mar 25, 2006 3:31 pm

Postby jackhk » Fri Jun 02, 2006 10:10 am

Yeah, i see.

Tell me about your iron's idea.
jackhk
 
Posts: 21
Joined: Thu Jun 01, 2006 4:56 pm

Postby Ice-tEA » Fri Jun 02, 2006 11:11 am

There's a remote chanfce Gateway cut some corners implementing the systems information to the MXM. AFAIK, it's implemented with a EEPROM on the motherboard of the AMilo. However, should Gateway have placed the EEPROM on the MXM itself this may cause problems when the DDC bus is probed during initialisation. The bus is screwed, the GPU doesn't understand and tells the system to go f**k itself, the system hangs.

As I said, just a hunch. Could work, tho. I'll try to confirm there's indeed a EEPROM on the card connected to the DDC bus. Should be able to do so today.
Upgrade your MXM graphics card!
http://Www.mxm-upgrade.com
Image
User avatar
Ice-tEA
 
Posts: 47
Joined: Sat Mar 25, 2006 3:31 pm

Postby jackhk » Fri Jun 02, 2006 12:02 pm

Well, i understand your idea.

I don't know if Gateway video Card have any EEPROM instead.

I can't see nothing various from 6800Go.

Little different component's disposition because new DDR3 modules and CORE.

But nothing seems any EEPROM over or under.

Tell me about some news.

Here an image:
http://img87.imageshack.us/my.php?image=go78001jj.jpg
Attachments
go78001jj.jpg
Last edited by aspettl on Fri Jun 02, 2006 12:02 pm, edited 1 time in total.
Reason: Borkar: Picture attached.
jackhk
 
Posts: 21
Joined: Thu Jun 01, 2006 4:56 pm

Postby Ice-tEA » Fri Jun 02, 2006 12:20 pm

There are a few components that could be an EEPROM. I have the exact same card here, I'll see if I can figure it out.
Upgrade your MXM graphics card!
http://Www.mxm-upgrade.com
Image
User avatar
Ice-tEA
 
Posts: 47
Joined: Sat Mar 25, 2006 3:31 pm

Postby jackhk » Fri Jun 02, 2006 3:17 pm

Ice-tEA wrote:There are a few components that could be an EEPROM. I have the exact same card here, I'll see if I can figure it out.


Oh, ok. May be probably. Tell me for some news.
jackhk
 
Posts: 21
Joined: Thu Jun 01, 2006 4:56 pm

Postby Ice-tEA » Fri Jun 02, 2006 6:41 pm

Hmmm There's an EEPROM on the DdcC bus, but there's one on all other cards I have, too. And these have been tested in you notebook.

I'm trying to decode the I²C address but I don't think I'll finish up today.
Upgrade your MXM graphics card!
http://Www.mxm-upgrade.com
Image
User avatar
Ice-tEA
 
Posts: 47
Joined: Sat Mar 25, 2006 3:31 pm

Postby jackhk » Fri Jun 02, 2006 8:20 pm

Ok. I'm still waiting for you.

Well, but i'm thinking: it can be notebook's BIOS problem?

May be BIOS can't recognize 7800Go because some modules in BIOS are outdate.

I'm trying to open Uniwill BIOS 1.11 with AMIBCP.

But AMIBCP won't work. An error "BIOS cecksum is bad" returned.

Can you help me to open and update BIOS?

I want to update only pcie modules like dell 9300's BIOS.

Because the question is: why dell 9300 can mount without problems any 7800Go or 7800Go GTX video cards?

I think because BIOS's modules are up to date and system can correctly handle any PciEx card.

What you think about?

Here BIOS 1.11: http://www.uniwill.com/UserDownload/p71 ... n0_111.zip
jackhk
 
Posts: 21
Joined: Thu Jun 01, 2006 4:56 pm

Postby Ice-tEA » Sat Jun 03, 2006 9:11 am

It could be, but I don't think so.

The whole point is that the video bios for these cards is on the cards themselves, pretty much like on normal desktop card. There's only a small part which details the system's information that is either in the system bios or on the dreaded EEPROM on the motherboard.

Accidently, do you think you coulr run the MXM test tool that is on my site (notinthelist page)? If you do, make sure you run it in native DOS mode as described.

I'm not sure I'll be able to give you an update today, as I am not at home. I'll do my best.

btw, áre you any good with the soldering iron? There are some harmless things we could try anyways. If properly done, it's easy enough to lift one or more pins of a SO-8 in a way that is easily reversible.
Upgrade your MXM graphics card!
http://Www.mxm-upgrade.com
Image
User avatar
Ice-tEA
 
Posts: 47
Joined: Sat Mar 25, 2006 3:31 pm

Postby jackhk » Sat Jun 03, 2006 7:35 pm

Ok.

I'll run your MxM Test Tool monday night, because i don't have my notebook right here.

I'm not pretty good with soldering iron. But i'm capable of, and i have all is needet to make my best.

The point is: think you problem is only any EEPROM on video card? Or also may be it's a Main Board's BIOS problem?

MxM Test Tool can answer this last question?

Is it any possibility that updating MB BIOS to recognize EEPROM's Video Card can we solve this mistery? What you think about?

Because thare are some ways to cover.
jackhk
 
Posts: 21
Joined: Thu Jun 01, 2006 4:56 pm

Postby Ice-tEA » Sun Jun 04, 2006 11:21 am

I would like to have you run the MXM test tool because I'm constantly looking for info, that may help you right now or perhaps it'll be a piece of the puzzle that will help someone else along the line.

I doubt it is BIOS related, as what you're doing is pretty much the same as exchanging a desktop card. That's why I'm thinkg hardware.

But I would like to avoid the impression that I'm sure this will work, there's a chance but to be honnest <i wouldb't value it any higher that 25% myself.

I'll see that I can take some pictures of what I'd suggest you'd do by Mondaty.
Upgrade your MXM graphics card!
http://Www.mxm-upgrade.com
Image
User avatar
Ice-tEA
 
Posts: 47
Joined: Sat Mar 25, 2006 3:31 pm

Postby jackhk » Mon Jun 05, 2006 8:56 am

If you need some other detail photos, tell me.

I was thining about BIOS update because on Dell 9300, like notebook- forums (no spam sry) tell, a BIOS update is needed in order to intall new 7800Go GTX.
jackhk
 
Posts: 21
Joined: Thu Jun 01, 2006 4:56 pm

Next

Return to Graphics, display

Who is online

Users browsing this forum: Google [Bot] and 0 guests

cron