amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

trouble with cpu multiplier after my li1705 cpu upgrade Topic is solved

Everything around CPU, RAM or cooling of notebook components.

trouble with cpu multiplier after my li1705 cpu upgrade  Topic is solved

Postby cdq » Tue Oct 09, 2007 1:07 pm

I everybody,

as i wrote in a previous post, i planned to upgrade my li1705 to core 2 duo or core duo or pentium dual core ...

I finaly did it after finding a good price on a t2350 core duo (1.86Mhz / FSB 533 socket 479 M)

First i flash my bios to be in 1.0D and then use my screwdriver

..everything went fine (the bios seemed to recognize a t2350 as it was writen during the boot sequence) until i realize performances where not very good... even worth than before. (geekbench returned 950 instead of 1450 before...)

after a quick reboot under Vista (i'm usualy under Linux), the situation is the same and the cpu-z tool returned me a multiplier of 6 for a cpu frequency of 800Mhz.... (this cpu is given for a multiplier from 6 to 14)

and the frequency doesn't get better under heavy load, the speedstep doesn't seem to work.

The good thing is that the laptop is quiter than before because the cpu is less warm ;-)
But i dit that in order to play Full HD videos and without power, it drops frames.

does anabody got same kind of problem ?
cdq
 
Posts: 13
Joined: Thu Aug 23, 2007 10:10 am
Location: Paris, France

Postby aspettl » Tue Oct 09, 2007 7:38 pm

Can you use dmesg (in Linux) and search for messages concerning your CPU (cpufreq, ...)?

Please post also the output of
Code: Select all
cat /proc/cpuinfo


Edit:
Did you reset your BIOS settings after installing the cpu? You can also try the hardware reset (see FAQ).

Regards
Aaron
User avatar
aspettl
Site Admin
 
Posts: 1347
Joined: Sat Mar 25, 2006 3:31 pm
Location: Germany
Notebook:
  • Lifebook E8020D

Postby cdq » Sun Oct 21, 2007 9:01 am

hi,

thanks for your help,
the hardware reset doesn't change anything.

i had a little success using cpufreq to change cpu frequency (but using it a strange way i think )
First, the centrino module doesn't load (no such device...) strange because my proc is a core duo.
the only way i founded was to use the acpi_cpufreq module with the following commands
to turn the frequency to 800Mhz
sudo cpufreq-set -c 1 -f 800
sudo cpufreq-set -c 0 -f 800
and the following do turn the frequency to 1.86Ghz
sudo modprobe -r acpi_cpufreq
sudo modprobe acpi_cpufreq

... yes, i was compelled to unload an reload the module to succeed...

the geekbench test then went from 950 to 1950 ! a big step
so now, i can say it's possible t upgrade from m520 to core duo without problem under linux

today i have upgraded my kubuntu distro to 7.10 (kernel 2.6.20.x to 2.6.22) and... miracle, the power manager now see the processor frequency, and it turn it up and down dynamicaly (centrino speedstep is working) !

so if you got such kind of trouble, first try an upgrade.

the remaining troubles (i can live with them) are: the fan (full power on startup, quiet only only after an hibernate/resume action
The screen which doesn't turn off at all (unless i close the screen, so i have to search for the script executed in such a case...)

Hope it may help someone else.
cdq
 
Posts: 13
Joined: Thu Aug 23, 2007 10:10 am
Location: Paris, France


Return to CPU, RAM, fan

Who is online

Users browsing this forum: No registered users and 0 guests