amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

La1703 Boot problem Ubuntu/Fedora/OpenSuse

Everything around Linux and Unix-like operating systems.

La1703 Boot problem Ubuntu/Fedora/OpenSuse

Postby nilsbalter » Tue Mar 04, 2008 2:54 am

I've tried ubuntu, fedora and openSuSE on my La1703, and everything seems to work until I try to boot it. Installation finishes perfectly and grub loads flawless. I can see the boot logo ("Ubuntu", "Fedora" and so on), but then, when the login-screen should appear, the monitor turns black. Same symptom on all three distributions.

I've tried adding noapic and noapic nolapic in grub, while booting, but that didn't work either. What should i do?

S3 VIA Chrome9 graphics
AMD Turion64
nilsbalter
 
Posts: 1
Joined: Tue Mar 04, 2008 2:48 am

Postby hikaru » Tue Mar 04, 2008 8:53 pm

I'm not that familiar with Ubuntu and Fedora but if you start Suse in comandline-mode (e.g. via the "Failsafe"-Entry in grub) you can reconfigure your X-server by running sax2. Maybe the automatic setup will be enough by just running:
sax2 -a

Then you should have at least a working GUI even if it doesn't look fine. But this can be changed by carefully modifiing the xorg.conf.

Maybe you can try other distributions too. Kanotix is known to support a lot of different hardware. And Debian works fine for me.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Postby powderedegg » Mon Mar 24, 2008 4:32 pm

7.04 Ubuntu worked for me, however 7.10 doesn't.

I too am running Debian 4.0 which so far is proving painless.
powderedegg
 
Posts: 4
Joined: Thu Sep 27, 2007 12:41 pm

Re: La1703 Boot problem Ubuntu/Fedora/OpenSuse

Postby abrasax » Fri Aug 15, 2008 5:35 pm

I have a feeling that if you boot with command xforcevesa it will work. chrome9 is realy bad graphics card. i know because i have the same laptop.
abrasax
 
Posts: 7
Joined: Fri Aug 15, 2008 5:20 pm


Return to Linux / Unix / BSD

Who is online

Users browsing this forum: No registered users and 0 guests