amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

Amilo d7830 wierd behaviour

All kinds of problems or malfunctions without known reason. Also general problems with the notebook as a whole.

Amilo d7830 wierd behaviour

Postby airbedman » Mon Mar 24, 2008 2:29 pm

Hi all,

i recently bought a used d7830 on ebay. When i tried to switch it on with the power connected the fans start up, the green light comes on and after about 5 seconds, switches off. I tried removing the battery (the ebay user told me it was dead) and it booted fine, However when I inserted a USB device of any sort, the machine powered off. So I got a replacement battery.

The replacement battery works just fine, even with 3 usb devices plugged in. My problem now is that, although the battery charges and the laptop will run off the battery, if I plug the power in while the battery is in, it just turns off the machine, and refuses to boot, same symptoms as when I had a dead battery. Im not sure what to check next, could it be the psu is faulty? Has anyone experienced anything similar?

I'm reluctant to put any more money into this, so any advice would be greatly appreciated.

Cheers.
airbedman
 
Posts: 4
Joined: Thu Feb 14, 2008 1:37 pm

Return to General problems

Who is online

Users browsing this forum: No registered users and 1 guest

cron