amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

4in1 card reader need to use it on a restricted account Topic is solved

Problems with hard drives, CD/DVD-devices, firmware updates, USB stick, card reader,...

4in1 card reader need to use it on a restricted account  Topic is solved

Postby smee » Sat May 17, 2008 11:43 am

Hello,

XP pro
V2020 pro fujitsu siemens

I am running my computer on a restricted account which I am happy with, I have one problem which I cannot solve though.
The 4in1 card reader is deactivated on the restricted account, and I cannot figure out how to activate it.
I cannot identify it in the hardware list either, maybe it has a different name.
I tried booting in safe mode (admin) but I cannot see any settings to render this little problem, my usb ports work fine though, so why deactivate the card reader??

Can anyone help?
The light at the end of the tunnel could always be an oncoming train !
smee
 
Posts: 23
Joined: Tue Aug 22, 2006 5:01 pm
Location: UK, York
Notebook:
  • Fujitsu Siemens Amilo V2020

Postby hikaru » Sat May 17, 2008 5:18 pm

I run mine on a restricted account too and my card reader works fine.
It appears as the following devices in section IDE ATA/ATAPI-Controller of my device manager:
- Ricoh Memory Stick Host Controller
- Ricoh MMC Host Controller
- Ricoh xD Picture Card Host Controller

The SD-Controller has its own section Secure Digital-Hostcontroller:
- SDA-Standard konformer SD-Hostcontroller
(german system)

These entries may vary, depending on your controllers.

Can you see the controller as Administrator (not in safe mode)? Does it work there? What happens if you temporarily give admin rights to your restricted account?
Which type of media would you like to access? SDHC doesn't work with the internal card reader.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Postby smee » Sat May 17, 2008 7:08 pm

Hi, and thank you

I also have a German OS, because I lived in Germany when I bough the Laptop, I use SuRun to run my applications which require admin, along with giving certain folders write access.

I checked for the Host Controller & this could be the problem. I could not get the Card reader to work under any other type of log in, maybe I am getting confused with my mothers Laptop.
The type of media is an SD card, this should work, I am now thinking that the host controller is not correctly installed.
I have a Basissystemgerät and 2 videocontrollers not correctly installed, I cannot install them with the triber CD.
I will have to consider a new install, this seems like it will not be resolved without it.

Do you agree? Thanx
The light at the end of the tunnel could always be an oncoming train !
smee
 
Posts: 23
Joined: Tue Aug 22, 2006 5:01 pm
Location: UK, York
Notebook:
  • Fujitsu Siemens Amilo V2020

Postby hikaru » Sat May 17, 2008 7:27 pm

I think a total reinstall from scratch isn't necessary.
In most cases the Basissystemgerät is the card reader.
A reinstall of your chipset driver should be sufficient.
This should also solve the problem with your video controller or at least make it possible to install drivers for it.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Postby smee » Sun May 18, 2008 1:27 am

Thanks again,

I tried to install the chipset driver as advised both in Admin & safe mode (admin), but the driver has not rectified the Basissystemgerät and 2 videocontrollers problem.

I am wondering what to do now, do you think removing the battery and power battery to reset bios would help?
The light at the end of the tunnel could always be an oncoming train !
smee
 
Posts: 23
Joined: Tue Aug 22, 2006 5:01 pm
Location: UK, York
Notebook:
  • Fujitsu Siemens Amilo V2020

Postby hikaru » Sun May 18, 2008 10:14 am

The hardware reset may help. At least it won't make anything worse.
But you don't have to remove the CMOS-battery.
Just remove battery and power pack and hold the power button for 10-15 seconds.

If you try the card reader with another OS (e.g. some Linux-LiveCD) you could find out if you have a hardware- or a software-problem.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Postby smee » Sun May 18, 2008 11:44 am

That is a good tip with not removing the CMOS battery, never knew that I never had to remove it.
I will let you know the results when I have finished.
The light at the end of the tunnel could always be an oncoming train !
smee
 
Posts: 23
Joined: Tue Aug 22, 2006 5:01 pm
Location: UK, York
Notebook:
  • Fujitsu Siemens Amilo V2020

Postby smee » Sun Jun 01, 2008 1:54 am

HI,

I did a full re-install today, and the system is working without any errors.

Thank you for your help.
The light at the end of the tunnel could always be an oncoming train !
smee
 
Posts: 23
Joined: Tue Aug 22, 2006 5:01 pm
Location: UK, York
Notebook:
  • Fujitsu Siemens Amilo V2020

Postby hikaru » Sun Jun 01, 2008 8:37 am

You ar welcome.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901


Return to Drives: HDD, DVD, card reader

Who is online

Users browsing this forum: No registered users and 0 guests

cron