amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

Battery working but not charging?

Problems with mainboard, BIOS, BIOS update, battery, AC adapter.

Battery working but not charging?

Postby SpectralQ » Fri May 30, 2008 12:15 pm

My laptop is M-1451G

Two weeks ago I had a weird incident with the power adapter. When I connected it to the (switched off) laptop, I smelled something burning and a little smoke came out from the keyboard. I quickly removed the adapter and handled the laptop to see what was going on but it seemed ok. After sometime I operated it on battery and it run ok. I worked on battery for half an hour and the battery levels dropped normally. I had my father test the power adapter and I even tried a spare one I have, and the laptop works fine except for the fact that it stopped being able to charge the battery.

The charging led is flashing as if it's charging the battery but even when left overnight, the battery levels remain the same and the led doesn't turn green.

Do you think there is a way to repair this?

Or at least, is there such a thing as an external battery charger for laptop batteries?

Thank you
SpectralQ
 
Posts: 2
Joined: Mon May 12, 2008 7:09 pm

Return to Mainboard, BIOS, battery

Who is online

Users browsing this forum: No registered users and 1 guest