amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

v3505 with the blank screen problem

Display problems, black screen, TV-Out,...

v3505 with the blank screen problem

Postby timecott01 » Thu Nov 20, 2008 3:19 pm

hello:
i have a amilo pro v3505 vl2 laptop which exhibits what seems to be a common problem (?) the problem is particularly bad when on battery power, the laptop screen goes black. the actual image on the screen is just visible if viewed with side lighting. the laptop is fully functional. an external monitor is unaffected. i have had the inverter replaced in the laptop to no effect - the going black problem persists. it occurs less frequently (but it still happens) when the laptop is on mains power.
it appears that the issue may be due to (windows) drivers? is a definitive fix known? i would like to get this problem sorted. i would appreciate any help with this.
timecott01
 
Posts: 3
Joined: Fri Apr 18, 2008 6:12 pm

Re: v3505 with the blank screen problem

Postby hikaru » Thu Nov 20, 2008 8:45 pm

If you already replaced the inverter it is most likely the backlight that doesn't work correctly. The only fix is to exchange it.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Re: v3505 with the blank screen problem

Postby timecott01 » Fri Nov 21, 2008 7:16 pm

Thank you for getting back. i am sceptical about the problem being the backlight itself as the pc seems to work ok if i boot from an ubuntu boot cd and use linux. in this case it does not exhibit the same problem - hence my thoughts about it being (win) driver based (i note that others on this forum refer to driver issues causing screen black problems - albeit on different models). is there a definitive driver version list for a win xp home build??? at least i could compare and d/l if i am missing a few updates.
any help appreciated.
tim ecott.
timecott01
 
Posts: 3
Joined: Fri Apr 18, 2008 6:12 pm

Re: v3505 with the blank screen problem

Postby hikaru » Sat Nov 22, 2008 10:03 am

Ok, if the problem only appears in Windows then it's obviously a driver issue.
You can get the official driver from the FSC-site:
http://support.fujitsu-siemens.com/COM/support/downloads.html
Enter your notebook model and operating system.

The graphics driver is listed as Device Driver. Maybe you should also reinstall the chipset driver or the whole OS.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901


Return to Graphics, display

Who is online

Users browsing this forum: No registered users and 0 guests