amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

L7300 Direct3d

Display problems, black screen, TV-Out,...

L7300 Direct3d

Postby bscdb » Sat Jun 13, 2009 4:53 pm

I have an Amilo L7300 which I installed Vista on last year. Although many of Vista's Aero features did not work the PC generally functioned well. Until .. Last month I installed a new hard drive. Instead of installing over XP I did a clean installation of Vista. The problem I am now having is that many basic features such as screensavers and other certain graphics that functioned before no longer work. I receive a Direct3d error message instead. Now I know many of the original drivers for the Amilo L7300 have not been updated for Vista but I am talking about graphics/settings which worked fine before. Any suggestions ?
bscdb
 
Posts: 3
Joined: Thu Jun 11, 2009 4:45 pm

Re: L7300 Direct3d

Postby aspettl » Tue Jun 16, 2009 7:08 pm

Did you install the original graphics driver provided by FSC?

Regards
Aaron
User avatar
aspettl
Site Admin
 
Posts: 1347
Joined: Sat Mar 25, 2006 3:31 pm
Location: Germany
Notebook:
  • Samsung NC10
  • Lifebook E8020D

Re: L7300 Direct3d

Postby bscdb » Wed Jun 17, 2009 9:10 pm

aspettl wrote:Did you install the original graphics driver provided by FSC?

Regards
Aaron


Thanks for the reply. Stupidly, no. I initially instaled xp and then straight after I installed vista as my vista disc is an upgrade version. Only once having done this did I remember the FSC disc that came with the laptop. This disc would then not run on my laptop (from .exe or from individually opening the files) which I presumed was due to the fact I had installed vista. I've scoured the FSC website for drivers but the only ones available for the L7300 seem to be for windows xp. Also the laptop will no longer play normal dvd's in windows media player or other media players. WMV files play but stutter. Installed Driver Detective but the problem remains. Hope I can avoid doing an xp, fsc disc, vista reinstall. Any bright ideas anyone ? :(
bscdb
 
Posts: 3
Joined: Thu Jun 11, 2009 4:45 pm

Re: L7300 Direct3d

Postby bscdb » Tue Jul 21, 2009 10:25 pm

I finally solved the problem and so thought I'd post the solution to save anyone else with a similiar problem the headaches I've had with this. The solution was simply a case of finding out how to install an xp driver on vista. I have pasted the steps below. Variations can easily be found by searching on google, bing etc.

Download the respective installer package for the driver you wish to install on Windows Vista. The installer package is located on the original manufacturer's installation disk that came with the device you're installing. It may also be available from the device manufacturer's website.

Step 2 Use your mouse to right-click on the installer package for the driver.

Step 3 Click "Properties" from the pop-up menu. A preferences window will appear on the screen.

Step 4 Click the tab that reads "Compatibility."

Step 5 Click the check box next to "Run this progam in compatibility mode for...."

Step 6 Select "Windows XP" from the drop-down menu and press the "OK" button to apply the changes and close the window.

Step 7 Install XP drivers in Vista. Double-click the XP driver's installer package. Windows Vista will now open the driver in Vista Compatibility Mode. The Windows Vista operating system will tell the XP driver that it is running on a Windows XP machine, thus allowing the installation process to continue where it would otherwise have stopped.

It may also help to tick the box at the bottom which says ''Run this program as an administrator'' :)
bscdb
 
Posts: 3
Joined: Thu Jun 11, 2009 4:45 pm


Return to Graphics, display

Who is online

Users browsing this forum: No registered users and 0 guests

cron