amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

Amilo Pro V2030 won't see my new SATA HDD

Problems with hard drives, CD/DVD-devices, firmware updates, USB stick, card reader,...

Amilo Pro V2030 won't see my new SATA HDD

Postby Pat » Tue Aug 25, 2009 6:05 pm

Evening Folks,

I have a V2030 that stopped booting up, it would just cycle to BSOD's. As an IT person with a few years experience, I decided the HDD was bust or the Windows installation is corrupt. I tried reinstalling Windows but was getting nowhere with it. Vista would just keep rebooting when I tried to install it, and XP would get stuck at around 65% of the installation process. I purchased a new SATA HDD this morning thinking that now everything would be right with the world - oh how wrong I was! I'm going to go through my steps 1 by 1 now.

1) Tried to install XP. It tells me there's no HDD found once I get to that stage.
2) I google it and find that XP doesn't come with SATA drivers. Pretty annoyed by this but OK, I'll deal with that.
3) Looked on Hitachi's website and they say their HDD's don't need drivers, it should be part of the motherboard driver.
4) Found this (http://news.softpedia.com/news/Install-Windows-XP-On-SATA-Without-a-Floppy-F6-47807.shtml) article elsewhere, followed it. It told me how to create a Windows disk which already had the drivers included. Downloaded all the relevant drivers from Fujitsu (Chipset, Graphics, LAN, think that should be enough). Created Windows Disk with those drivers already included. I boot the machine again, it goes straight to the Windows installation, and still says that no HDD is installed in my machine. Bios also says there is no HDD installed.
5) Post here.
6) Win?

Thanks in advance guys. I was looking forward to a whole day of Call Of Duty today but no, I have to fix this laptop for my friend, and it has to be the most awkward piece of trash I've ever come across!

The HDD I purchased is a Hitachi 5K500 B-160, HTS545016B9A300. It's 160GB with 5400RPM.

Before someone mentions the obvious, I don't have the original disk that came with the laptop for reinstalling Windows.

Thanks again. I'm off out now but will check back in a few hours. If I've missed any information that you need to figure this out, just let me know.
Pat
 
Posts: 3
Joined: Tue Aug 25, 2009 5:50 pm

Re: Amilo Pro V2030 won't see my new SATA HDD

Postby hikaru » Wed Aug 26, 2009 8:07 am

Did you try a hardware reset after installing the new HDD?:
https://www.amilo-forum.com/topic,11,-Hardware-F-A-Q.html

If the BIOS then detects the HDD but Windows still won't install try xpisobuilder instead of nlite. Sometimes one of them works while the other one does not:
https://www.amilo-forum.com/topic,26,-Installation-of-Windows-XP-Home-Pro-PE-FAQs.html
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Re: Amilo Pro V2030 won't see my new SATA HDD

Postby Pat » Wed Aug 26, 2009 12:12 pm

Thanks, but that hasn't worked. I installed the drivers from http://www.viaarena.com/Drivers.aspx?Pa ... CatID=1180 in the package - most of the links are duplicates and only the 580F package actually contains a txtsetup.oem file. Still when booting to windows, it won't find the hard drive. The hardware refresh didn't work either. I've tried it with both Windows compilers now, although when I tried it with nlite, I was using the chipset drivers rather than the specific VIA drivers, but I just get the distinct feeling I'm not on the right track here.

I noticed a very minor difference this time though. The previous times when I was attempting to install Windows, it always asked me to make a choice, press enter to install windows etc. This time it did not. It just cycled through and arrived at the "no drive found" bit.

Thanks in advance for any further advice.
Pat
 
Posts: 3
Joined: Tue Aug 25, 2009 5:50 pm

Re: Amilo Pro V2030 won't see my new SATA HDD

Postby hikaru » Wed Aug 26, 2009 12:35 pm

Pat wrote:The hardware refresh didn't work either.
Does this mean that the BIOS still doesn't detect the HDD? Unless it does you don't even need to try to install Windows because even with the correct driver Windows can only detect what the BIOS reports.

Are you sure that it's your old HDD that got defective and not the controller? What about the new HDD? Did you test it in another computer or externally?
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Re: Amilo Pro V2030 won't see my new SATA HDD

Postby Pat » Thu Aug 27, 2009 10:02 pm

Sorry for the delay, I couldn't face looking at the laptop for a while, it's making me so angry! I just tested both HDD's in my desktop machine and both worked. I also want to bring to your attention that even the old HDD would work in the laptop for a short while but when Windows was installing, usually around 50-70%, it would stop completely and the only way to get the laptop to do anything was to hold the power button. The old HDD is recognised in the BIOS no problem, but the new one still isn't. I even updated the BIOS yesterday with the latest version in case that was a problem.
Pat
 
Posts: 3
Joined: Tue Aug 25, 2009 5:50 pm

Re: Amilo Pro V2030 won't see my new SATA HDD

Postby frogfeet » Thu Nov 26, 2009 8:52 pm

test your memory. memory fails too. your symptoms sound eerily similar to ones i had and after monkeying for daze i finally checked the memory and presto, that was the problem
frogfeet
 
Posts: 6
Joined: Sun Jan 04, 2009 10:31 pm


Return to Drives: HDD, DVD, card reader

Who is online

Users browsing this forum: No registered users and 0 guests