amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

Wireless suddenly stopped working - M1437G and Win7

All problems with windows and windows drivers.

Wireless suddenly stopped working - M1437G and Win7

Postby globalste » Tue Dec 01, 2009 10:28 pm

Hi there

First post, and major frustration with my wife's Amilo.

Installed windows 7 and everything seemed to run fine. It had no sound, but I managed to find an older driver that made it work fine. Installed Windows on the 25th October - its the Home Premium edition 32bit.

On Friday the wireless device suddenly decided that it would only give limited connectivity. I tried everything including deleting the device and having windows automatically detect it was missing and reinstall itself. All to no avail. The LAN port doesnt seem to work either so I cannot connect the machine to the internet. I took it to a computer repair shop after spending hours and giving up, I have just received the following email:

"No luck I’m afraid. We’ve tried to install new drivers for both wireless and network adaptors (from Intel website) – none are compatible. We’ve tried new Win 7 chipset, no luck. Looking on the Fujitsu website, unfortunately, this laptop is not compatible with Windows 7 – the operating system is on there but the software just won’t work properly – driver issue obviously. I would advise rebuilding with Win XP." :roll:

Now I know this machine works with Win 7 because Ive had it running myself! Trying to find a solution without having to wipe clean and re-install...

Any help is greatly appreciated, otherwise the computer feels like a write-off :(
globalste
 
Posts: 2
Joined: Tue Dec 01, 2009 10:20 pm

Re: Wireless suddenly stopped working - M1437G and Win7

Postby aspettl » Wed Dec 02, 2009 9:24 am

Just an idea:
You also get limited connectivity if the encryption doesn't work (e. g. wrong key). So I'd try to connect to an unencrypted wireless network - just to make sure this isn't the problem. (Of course I don't know what tests the repair shop already did.)

Did you already try the Windows System Restore?

Are you sure the wireless switch is on (does the Intel driver say so)?

Regards
Aaron
User avatar
aspettl
Site Admin
 
Posts: 1347
Joined: Sat Mar 25, 2006 3:31 pm
Location: Germany
Notebook:
  • Samsung NC10
  • Lifebook E8020D

Re: Wireless suddenly stopped working - M1437G and Win7

Postby globalste » Wed Dec 02, 2009 10:21 am

Thanks for the reply

Yes checked wireless switch is on. Driver recognises it is on. Windows check says everything is fine. No restore point created yet unfortunately otherwise i would have tried that as well.

Interestingly when I completely deleted the driver etc and wiped all trace of my wireless network, when I tried to reconnect it said that the WEP key was wrong!

Other laptops running Win7 and XP in the house connect fine to wireless.

Really strange, got me totally stumped. Would send back to Fujitsu for them to look at, but their website (which annoyingly goes to german for anything service related) says that the 1437G is not suitable for Win 7, which i suspect will be their standard response.

I also tried installing my 3G card and accessing internet through that - that didnt work either :(
globalste
 
Posts: 2
Joined: Tue Dec 01, 2009 10:20 pm


Return to Windows

Who is online

Users browsing this forum: No registered users and 0 guests