amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

[Amilo pi1505] Battery not charging but powering ac adaptor

Problems with mainboard, BIOS, BIOS update, battery, AC adapter.

[Amilo pi1505] Battery not charging but powering ac adaptor

Postby squeezeme » Sat Jan 30, 2010 3:32 pm

Hi everyone.

I'm new here, but I've been reading this forum for a while and always found it somehow useful when I had issues witn my Amilo pi 1505, so far.

So, this is the problem:

About a year ago I had something like a short circuit to the adapter of my pi1505 while the notebook was on with the original battery (that was a bit old but never gave problems) and the adapter broke.
I borrowed a new adapter from a friend and noticed something weird: when the notebook was connected without the battery it worked totally fine.
When I got it connected to the battery too (to recharge it) the orange light blinked something like a a minute and stopped, without recharging anymore.
Moreover I noticed that if I had the battery on and the adapted connected to the notebook but not plugged to the electricity, the LED on it stayed on as if the battery was sending power to it.

After a read around on this very forum and somewhere else online, I blamed my old battery for this (it was about 2 years old) so I started working without it and never had any problems. Since then, only think that i noticed is that the charging led on the notebook in rare occasions blinked a couple of times with no reason.

Lately because of my studies I strongly need to carry my laptop around so i bought a new battery and also a new adapter thinking that new equipment would have solved the problem.
Unfortunately my problem is still there: the new battery works totally fine (I tried it on my very own notebook and when it's charged it works, and I also charged it on another pi1505 without problems), the new ac adapter is perfect but I still cannot charge the battery. The orange led blinks for a while and that's it.
On the other hand, if I plug battery + adapter, the led on the adapter stays on without any electricity supply.

ps. i tried the hardware reset but i got nothing solved :(

Well, I tried to be as precise as possible... if anyone can help it would be much appreciate :)

All the best to the forum and thanks everyone.


squeezeme
squeezeme
 
Posts: 2
Joined: Sat Jan 30, 2010 3:02 pm

Re: [Amilo pi1505] Battery not charging but powering ac adaptor

Postby damonbotley » Fri Feb 12, 2010 12:23 pm

Hi there, I just wondered if you found a solution to this problem? I think I have something similar. The computer runs off mains power but is not charging the battery at all.

Damon
damonbotley
 
Posts: 13
Joined: Sat Mar 01, 2008 8:32 pm
Location: UK

Re: [Amilo pi1505] Battery not charging but powering ac adaptor

Postby squeezeme » Tue Feb 23, 2010 10:26 pm

Hi. No solution whatsoever.
But I found out that the battery actually chargers for a while (when the led blinks). If I pull out the power jack, wait for a while and then plug it again it charges for some more, than stops again.

After doing it several times I checked the battery status and it was half charged... so the question is: why doesn't the laptop charge it continuosly?

If anyone knows, please tell us :)
squeezeme
 
Posts: 2
Joined: Sat Jan 30, 2010 3:02 pm


Return to Mainboard, BIOS, battery

Who is online

Users browsing this forum: No registered users and 0 guests

cron