amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

ATI Mobility Radeon X700 in M1437G

Display problems, black screen, TV-Out,...

ATI Mobility Radeon X700 in M1437G

Postby ken.dearden » Thu Feb 25, 2010 2:50 pm

The screen goes blank usually at the point when I move the mouse pointer to enter my password to log in to Windows XP. Occasionally, Windows XP will load and the screen may then go blank at any time.

I recently uninstalled the graphics hardware in Windows, removed the driver software and reinstalled it. This seemed to solve the problem for a couple of weeks and now it is back. I have tried the hardware uninstall/reinstall technique again to no avail.

The screen works fine in safe mode and in normal mode with a VGA Compatible Video Driver, except that I do not have access to the second screen used by the video-out connection, which is connected to my television screen.

My assumption is that the graphics hardware is faulty. Does anyone have any other suggestions or agree with this diagnosis?

If my graphics card is faulty, does anyone know where I can obtain a (new) replacement card at a realistic price (a web site would be useful)? Fujitsu's official spares are very expensive for such an old card, although it might be my only option.

Also, assuming I do need to replace the graphics card in my laptop, does anyone have nice, easy, step-by-step instructions for so doing? I did qualify as an electronics engineer a lifetime ago but the intricacies of accessing the innards of modern laptops often defeats me.

Thanks to all who read this plea for help and even greater thanks to anyone who comes up with a practical repair strategy that costs less than the laptop is now worth.
ken.dearden
 
Posts: 2
Joined: Thu Feb 25, 2010 2:20 pm

Re: ATI Mobility Radeon X700 in M1437G

Postby hikaru » Thu Feb 25, 2010 3:13 pm

ken.dearden wrote:My assumption is that the graphics hardware is faulty. Does anyone have any other suggestions or agree with this diagnosis?
That's my conclusion too. Theoretically it could also be the RAM or the main board. But most likely it's a defect of the graphics card itself.
The only way I see to get a replacement at a reasonable price is to buy a second-hand card. Notebook graphics cards are not available on the free market like desktop cards. Therefore you won't find a new one in a regular store.

In our german forum we have a tutorial for replacing the graphics card in a M1437g:
https://www.amilo-forum.de/topic,26768,-Anleitung-zum-Austausch-der-GraKa-am-Beispiel-des-M1437G.html

Unfortunately nobody was diligent enough to translate it (including me), but it has its main information from two other how-tos:
http://www.mxm-upgrade.com/1437.html
http://www.mxm-upgrade.com/3438.html
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Re: ATI Mobility Radeon X700 in M1437G

Postby ken.dearden » Mon Mar 01, 2010 4:07 pm

Thanks hikaru.

I did learn German many years ago but I have forgotten most of it.

I have taken the brave step of looking inside the laptop and I have not only found the graphics card but I have also removed it and put it back again to see if that fixed the problem. Not unexpectedly, it didn't. I am still seraching for a replacement card. At least, now, if I find one, I know how to replace it.
ken.dearden
 
Posts: 2
Joined: Thu Feb 25, 2010 2:20 pm


Return to Graphics, display

Who is online

Users browsing this forum: No registered users and 0 guests

cron