amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

resolved ubuntu will not start almost never Topic is solved

Everything around Linux and Unix-like operating systems.

resolved ubuntu will not start almost never

Postby cobraviola » Sun Mar 21, 2010 11:26 am

Hi, sorry for my English, I'm going to describe this problem I brought it back already from Ubuntu 8.04. 1 that happens once every 3-4 start to fail and that shows the karmic grub (no countdown!) And after boot logo karmic (white ones) black screen! I am forced to shut down forcibly. I am a bit tired of this issue also because it often presents on karmic Can you help?

Annex 2 xorg I have taken after the forced shutdown via live.
Attachments
xorg.1.log.doc
(155.5 KiB) Downloaded 338 times
xorg.0.log.doc
(538.5 KiB) Downloaded 382 times
Last edited by cobraviola on Fri Apr 09, 2010 5:41 pm, edited 1 time in total.
cobraviola
 
Posts: 7
Joined: Mon Jan 26, 2009 2:11 pm

Re: ubuntu will not start almost never

Postby hikaru » Mon Mar 22, 2010 7:51 am

It seems like your graphics card isn't detected correctly:
Code: Select all
(II) Module fbdevhw: vendor="X.Org Foundation"
   compiled for 1.6.4, module version = 0.0.2
   ABI class: X.Org Video Driver, version 5.0
(EE) open /dev/fb0: No such file or directory
(II) resource ranges after probing:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] 0   0   0x000a0000 - 0x000affff (0x10000) MS[B]
   [5] 0   0   0x000b0000 - 0x000b7fff (0x8000) MS[B]
   [6] 0   0   0x000b8000 - 0x000bffff (0x8000) MS[B]
   [7] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [8] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
   [9] 0   0   0x000003b0 - 0x000003bb (0xc) IS[B]
   [10] 0   0   0x000003c0 - 0x000003df (0x20) IS[B]


Please create an xorg.conf with the appropriate content for your graphics card. Unfortunately you neither gave any information about your notebook model nor about your graphics card. So I can't tell you what's the right configuration.

btw:
Please don't hide any logs in proprietary formats. Just use plain text files or the code tags.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Re: ubuntu will not start almost never

Postby cobraviola » Mon Mar 22, 2010 4:27 pm

Thank you for your reply, sorry for my english, is a notebook siemens amilo LI1718 here's characteristics
Code: Select all
lspci
00:00.0 Host bridge: ATI Technologies Inc Device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 83)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller:ATI Technologies Inc RC410 [Radeon Xpress 200M][/color]
02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
0a:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
cobraviola
 
Posts: 7
Joined: Mon Jan 26, 2009 2:11 pm

Re: ubuntu will not start almost never

Postby hikaru » Mon Mar 22, 2010 5:33 pm

An Li 1718 with an ATI Xpress 200M, I see.

Maybe this will help:
https://help.ubuntu.com/community/RadeonDriver

The proprietary fglrx driver doesn't support the 200M anymore. So install the free radeon driver:
Code: Select all
sudo apt-get install xserver-xorg-video-radeon

If you are asked to remove any fglrx packages confirm this. You don't need them.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Re: ubuntu will not start almost never

Postby cobraviola » Mon Mar 22, 2010 9:20 pm

Hello I tried your suggestion but xserver-xorg-video-radeon is already the newest version.
cobraviola
 
Posts: 7
Joined: Mon Jan 26, 2009 2:11 pm

Re: ubuntu will not start almost never

Postby hikaru » Wed Mar 24, 2010 10:38 am

Ok, then it seems you need a proper xorg.conf. I guess so far there is no file /etc/X11/xorg.conf on your system. Create one according to the how-to I linked in my previous post!

I'm not absolutely sure how it has to look like, but maybe this could work (watch out for the #comments!):
Code: Select all
Section "Device"
        Identifier      "Radeon Xpress 200M" #just a name, doesn't matter if it's always the same
        Driver          "ati"
        BusID           "PCI:1:0:0"
        Option          "XAANoOffscreenPixmaps" #no idea what this does, maybe skip it
EndSection

Section "Monitor"
        Identifier      "Generic Monitor
        Option          "DPMS"
        HorizSync       28-72 #not sure if this value is correct, maybe likely not (will handle that later)
        VertRefresh     43-60 # same here
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Radeon Xpress 200M"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "1280x800" "1024x768"
        EndSubSection
EndSection

Section "DRI"
        Mode 0666 #not sure what this does, but seems to be important
EndSection
       
Section "Extensions"
        Option "Composite" "Enable" #same here
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection


Ok, back to those frequencies in Section "Monitor":
You can find the correct frequencies with cvt. This should be what you need:
Code: Select all
cvt 1280 800 60
# 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
vsync (59,81Hz) and hsync (49,80kHz) are within the ranges specified above. So it should work.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901

Re: ubuntu will not start almost never  Topic is solved

Postby cobraviola » Fri Apr 09, 2010 5:40 pm

Hello, thank you for the assistance I solved the problem by reinstalling karmic, I discovered that the installation CD had 7 errors. I reinstalled with an ISO karmic error-free and the problem is not presented. :P
cobraviola
 
Posts: 7
Joined: Mon Jan 26, 2009 2:11 pm


Return to Linux / Unix / BSD

Who is online

Users browsing this forum: No registered users and 0 guests