amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

Amilo Li1718 - USB Ports Not Working...

Housing, keyboard/touchpad, sound/mic and everything else that doesn't fit into the other hardware forums.

Amilo Li1718 - USB Ports Not Working...

Postby chandelirious » Mon Aug 16, 2010 10:28 am

Hi all, I wonder if you can help me with an ongoing problem...

None of my 4 USB ports on my laptop are being recognised - I have a sneaky feeling that this is following a recent Windows Update (but that could be a coincidence).

It doesn't matter what I plug in, nothing is recognised. A bit of Googling gave me this solution:
Locate the file INFCACHE.1 in C:\Windows\inf
Right click on the INFCACHE.1 file, select Properties >Security > Edit, >and give your username full control.
Rename it to INFCACHE.1.BAK
Reboot your PC and it should reinstate the USB driver files.


Unfortunately, it did not work.

So, I posted the problem on another forum that I frequent, and I got offered this solution:

Forum: Go to You Device Manager...<--just type this in the start search field in the start menu...go down to universal serial bus controllers and click the plus sign...all your USBs will drop down...right click on all of them and uninstall all of them...if there are yellow triangles next to them then you may have to go to the manuf. website and update them or do a recovery if you have some kind of corruption.

My reply: No yellow triangles, all drivers are up to date...

Forum: uninstall them anyways

My reply: Done this, problem solved! As I started Uninstalling them, it started reinstalling them, and hey presto! problem solved.


Unfortunately, that seemed to be only a temporary solution, as the next day the problem re-presented itself.

I have since tried the following:

Suggestion: Download and burn a linux distro to CD/DVD. Install linux.
Result: Did this as a Dual Boot. I've so far plugged in an external hard drive - lights up, but nothing comes up on the system. Same with my Nokia N900.

Now here's some interesting points:
* My USB fan works when plugged in.
* My N900, when plugged in, says "Not charging. Insufficient power." Even though "Connect as mass storage mode" appears, it doesn't work
* The external hard drive is obviously receiving some power, but it is not recognised by either Windows or Ubuntu.
* The laptop is a Fujitsu Siemens Amilo LI1718, running Windows Vista.
* The drivers for the USB ports are from 2006, but I cannot for the life of me find an update anywhere online.
* The ports have recently taken a knocking - the USB fan was plugged in, my wife picked up the laptop but not the fan, the fan tugged on the USB port. But that was just one of them.

I'm totally stuck, and you only realise how much you use your USB ports when you can't use them anymore...

Additional help from online:
Sounds to me like the USB ports are physically *****, like maybe one or more solder joints inside the laptop have cracked and the connection is intermittent. Consistent power (e.g. to power your USB fan) doesn't necessarily mean it has all it needs for normal USB data transfer.
If your laptop isn't under warranty any longer, and you're somewhat handy with electronics, you could crack open the laptop, examine the USB port area with a multimeter to check for a short, and if possible re-solder any bad joints. If the mainboard is cracked, you might need a more exotic fix (like trying to bridge the gap with wire, or obtaining a new mainboard).


Haven't opened it up yet, but not really sure if I can handle soldering... not that I have any gear to do it with anyway...

So. Has anyone experienced anything like this? Has anyone any idea what I could do next?
chandelirious
 
Posts: 2
Joined: Sun Feb 14, 2010 12:11 pm

Re: Amilo Li1718 - USB Ports Not Working...

Postby aspettl » Tue Aug 17, 2010 10:21 am

Hi

Did the USB ports work normally after you removed the drivers? (I mean, on the same day or without restarting Windows.)
Could you try that again and test it once more with your USB devices?

It's ok that the drivers are old.

Does your external hard drive have its own power supply?
Does an external mouse or keyboard (or another device that requires nearly no power) work via USB?

Regards
Aaron
User avatar
aspettl
Site Admin
 
Posts: 1347
Joined: Sat Mar 25, 2006 3:31 pm
Location: Germany
Notebook:
  • Samsung NC10
  • Lifebook E8020D

Re: Amilo Li1718 - USB Ports Not Working...

Postby chandelirious » Tue Aug 17, 2010 11:54 am

Yes, funnily enough, the USB drives DID work after I'd uninstalled them - they just reinstalled themselves, and worked straight away without a reboot.

The USB Hard Drive doesn't have it's own power supply, it is powered solely by USB.

I tried a Microsoft Mouse, didn't work at all - didn't even light up - in either Ubuntu or Windows.
chandelirious
 
Posts: 2
Joined: Sun Feb 14, 2010 12:11 pm

Re: Amilo Li1718 - USB Ports Not Working...

Postby hikaru » Mon Aug 23, 2010 8:02 am

It sounds like the USB power supply is broken. This might occur when 2.5" HDDs are used bus-powered since they all consume more power than is specified for USB 2.0. Therefore HDDs should always be driven self-powered (i.e. with an external power pack), no matter what the advertisement of the manufacturer says.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Dell Precision M6500
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901


Return to Other hardware

Who is online

Users browsing this forum: No registered users and 0 guests

cron