amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

Amilo 1655g with Turion ML-37 does not start

All kinds of problems or malfunctions without known reason. Also general problems with the notebook as a whole.

Amilo 1655g with Turion ML-37 does not start

Postby mesti » Wed Feb 28, 2007 9:46 am

Hi,
Recently I have bought an 1655g without CPU, HDD, RAM, optical drive, the seller (a computer repairmen) told me it was testes ok by them. Several months passed, and now I got myself a Turion CPU. After installation I tried to switch on the machine, but the screen remains blank, I can't enter to BIOS, the fan does not move, althogh HDD and the optical drive spinds up, the CPU feel slighly warmer (I have tried this or like 30 secs, so it wasn't hot at all).
I tried removing the CMOS battery to clear CMOS, and also removed battery and AC cable, and pressed switch button for 30 sec.
Could that be an problem with old BIOS? Is there any way to update it with a desktop CPU installed? (I don't have access to a Mobile Athlon, only desktop 754 Sepmron, but I get similar results with that).
I also noticed the DIP-like switch under the keyboard (four two-phase switch) numbered and keyed, is there any documentation on that.
All I could find out, that the mainboard is FIC Kw2r type, although Hannstar is written on the board.
Any help is appreciated.
Thanks,
Tibor
mesti
 
Posts: 3
Joined: Tue Feb 27, 2007 6:14 pm

Postby aspettl » Wed Feb 28, 2007 10:41 am

Did you install RAM? (not mentioned above)
Which Turion is it?

Regards
Aaron
User avatar
aspettl
Site Admin
 
Posts: 1347
Joined: Sat Mar 25, 2006 3:31 pm
Location: Germany
Notebook:
  • Lifebook E8020D

Postby mesti » Wed Feb 28, 2007 10:55 am

Yes, I installed proper RAM (two Hynix 333Hz 256Mb moduls, tested ok on Amilo 1310g).
The processor is Turion ML-37, 2 GHz. If you search the web, you can find 1655g with ML-37 installed.
mesti
 
Posts: 3
Joined: Tue Feb 27, 2007 6:14 pm


Return to General problems

Who is online

Users browsing this forum: No registered users and 0 guests

cron