amilo-forum.com

Everything you need to know about Amilo and Lifebook laptops by Fujitsu

wifi on ubuntu / Amilo M3438G: almost there Topic is solved

All about LAN/WLAN and Internet.

wifi on ubuntu / Amilo M3438G: almost there

Postby drhex » Fri Sep 24, 2010 8:29 pm

Hi there. I'm trying to get wifi working on an Amilo M3438G. With some googling and testing I've gotten this far:
* Wired internet works fine.
* The "wireless" button on the amilo's case is in the "ON" position, blue wifi lamp below display is lit.
(It seems the button does work in Linux: the output of "iwconfig" changes from "no radio" to "unassociated" when I turn the button from off to on)
* Verified that it is possible to contact the wireless router from the amilo's location using another wifi device.
* The network card is "Intel PRO/Wireless 2200BG", for which there is kernel support (ipw2200).
* Ubuntu 10.04 with the latest updates is installed.
* BIOS version is 1.10C, (the latest, I think). I found no wifi-settings in the BIOS.

Testing like so:
ifconfig eth0 down # disable wired internet
ifconfig eth1 up # enable wifi interface
iwlist eth1 scan # will list several nearby access points, including mine.
# no other access point is using the same channel as mine.
iwconfig eth1 essid DRHEX_WLAN # tell it which access point to connect to
iwconfig eth1 key 0123456789abcdef0123456789 # actual WEP key has this length
dhclient eth1 # tries for a while, then says "No DHCPOFFERS received"
ping 74.125.77.147 # says "Network is unreachable", why?

Output of "ifconfig":

eth1 Link encap:Ethernet HWaddr 00:12:f0:57:d6:9a
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:5 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:84 (84.0 B)
Interrupt:19 Memory:fa9fe000-fa9fefff

lo Link encap:Local Loopback
<more lines about lo>

Output of "iwconfig":

eth1 unassociated ESSID:"DRHEX_WLAN"
Mode:Managed Frequency=2.447 GHz Access Point: 00:08:A1:81:9A:9E
Bit Rate=0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:0123-4567-89ab-cdef-0123-4567-89 Security mode:open
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

"dmesg | grep 2200" says things like

[ 18.733953] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 4995.952845] ipw2200 0000:01:03.0: firmware: requesting ipw2200-ibss.fw
[11534.812224] ipw2200 0000:01:03.0: PCI INT A disabled
[11536.740810] ipw2200 0000:01:03.0: restoring config space at offset 0xf (was 0x18030100, writing 0x18030103)
[11536.740826] ipw2200 0000:01:03.0: restoring config space at offset 0x4 (was 0x0, writing 0xfa9fe000)
[11536.740831] ipw2200 0000:01:03.0: restoring config space at offset 0x3 (was 0x0, writing 0x4008)
[11536.740838] ipw2200 0000:01:03.0: restoring config space at offset 0x1 (was 0x2900000, writing 0x2900016)
[11537.988174] ipw2200 0000:01:03.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[11542.208894] ipw2200 0000:01:03.0: firmware: requesting ipw2200-bss.fw

"cat /proc/interrupts | grep 19:" says

19: 995826 IO-APIC-fasteoi uhci_hcd:usb3, ipw2200

What else can I try?
drhex
 
Posts: 6
Joined: Fri Sep 24, 2010 7:51 pm

Re: wifi on ubuntu / Amilo M3438G: almost there  Topic is solved

Postby aspettl » Sat Sep 25, 2010 4:18 pm

Hi

I think it's a problem with encryption. Thus, DHCP does not work, and you have no IP address.

Why don't you use the network manager of Ubuntu? I had no problems with it for some years, it's also a lot easier, especially with WPA. This is another thing I wanted to mention: if possible, you should switch to WPA or WPA2 instead of WEP.

Regards
Aaron
User avatar
aspettl
Site Admin
 
Posts: 1347
Joined: Sat Mar 25, 2006 3:31 pm
Location: Germany
Notebook:
  • Samsung NC10
  • Lifebook E8020D

Re: wifi on ubuntu / Amilo M3438G: almost there

Postby drhex » Sat Sep 25, 2010 9:55 pm

Thanks for the reply!

I'm using WEP rather than WPA because the network also contains an old computer whose network card can't do WPA.
I wanted to solve the problem with shell commands because when I tried the GUI networking tools it:
* Asked me for an essid and wep key, then said "connection established" but I still couldn't ping or surf anywhere.
* Kept bugging me for a "keyring password", which I couldn't get rid of (this machine is supposed to be password-free)

I have disabled the WEP key on the wireless router and enabled wifi using the gui tools, and it actually works now, with no passwords, so at least I know the hardware is ok.
Now, let's see if it still works when I turn encryption back on...
drhex
 
Posts: 6
Joined: Fri Sep 24, 2010 7:51 pm

Re: wifi on ubuntu / Amilo M3438G: almost there

Postby drhex » Sat Sep 25, 2010 11:20 pm

Well, it does work with WEP enabled too.
Too bad I don't know what I did right this time, because the machine will soon be re-installed with a shiny new harddrive, meaning I'll have to start over again.
drhex
 
Posts: 6
Joined: Fri Sep 24, 2010 7:51 pm

Re: wifi on ubuntu / Amilo M3438G: almost there

Postby hikaru » Mon Sep 27, 2010 10:12 am

If you just replace the hard disk because of its size and would rather keep your existing system, you could clone the old HDD to the new one instead of doing a complete reinstall.
User avatar
hikaru
Moderator
 
Posts: 1153
Joined: Thu Oct 25, 2007 9:23 am
Notebook:
  • Dell Precision M6500
  • Amilo Si 1520
  • Desktop
  • Asus EEE 901


Return to Networking and Internet

Who is online

Users browsing this forum: No registered users and 0 guests

cron